Cannot receive email with MX records

I just switched back from Gmail for my business email to my host provider. I have everything setup correctly but the email is not working properly and I’m getting a “!” about exposing my IP address. This was never an issue prior to switching to Gmail.

Now, I cannot send nor receive email. What am I missing?

Your settings are correct. mail.yourdomain is a functioning mail server. You may have to re-configure your mail client to point to the correct hostname for sending and receiving email.

As for the ! warning, this is normal, as you’re hosting email on the same server as your website, so you have to expose that IP address (Cloudflare does not proxy email).

Thanks. It’s working now.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.