Cannot receive email: Error 550 5.1.1. "Domain does not exist"

Since I have started using Cloudflare, I have been unable to receive email. Sending seems to be no problem, though.

The sender gets an error message about the domain not existing (code 550 5.1.1) from amir.mx.cloudflare.net.

Inked511_LI

I understand the email service is still in beta, but I would really appreciate any help to solve this.

How are you trying to use the Email service? Did you have a service before enabling Cloudflare’s email service?

Hi,

This article might help here:

Please let us know if issue is resolved.

@AxTi The error was due to an old bug on our side. I manually enabled your zone, if you toggle the catch-all on the dashboard it should start working.

2 Likes

Yes, it seems to work fine now. Thank you!

1 Like

Hi again! The problem was solved for a few days, but now it has reoccurred. Have the bug returned?

1 Like

@AxTi Could you please send a screenshot of your Email tab on the dashboard? You can DM me on Cloudflare dev’s discord or send an email to sven (at) Cloudflare.

Thank you for a rapid response. I have sent you an email.

For the record: the problem was on my end this time and now it works again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.