Cannot pay for the domain transfer

billing

#1

Trying to transfer domain to CF, but the payment is not working. I’ve tried different card for the payment in the billing but the result is always the same:

Something went wrong

xxxxxxxxxxxxx (domain name ware replaced for privacy purposes)

Your payment has been declined. Please check with your payment provider or try again with a different payment method.

Want to stop overpaying for the rest of your domains? Add them to your Cloudflare account and you’ll be able to transfer them to Cloudflare Registrar immediately.

I really don’t want to use PayPal as payment option.

Regards,
-Tiho


#2

Same issue as yours.


#3

This situation is best addressed by contacting support directly. Go to https://support.cloudflare.com/, log in and open a ticked.

You may also want to check whether there’s any temporary issue affecting billing at your region by looking at:

https://www.cloudflarestatus.com


#4

Same problem here. Tried different cards from different banks and all declined.

This happened to me when trying to transfer 5 domains at the same time. I suspect that CF is putting through 5 individual transactions and this is causing a trigger with the card issuer.

Can’t be bothered using CF for domain transfers if this keeps happening. Too much hassle to keep entering unlock codes after a failed transaction. Domains don’t stay in a shopping cart and one has to restart from scratch each time.

Sort out your payment back end - it’s a mess.


#5

I am having similar issues as OP, but I am using paypal and trying to do it on just one domain.


closed #6

This topic was automatically closed after 14 days. New replies are no longer allowed.