Cannot open my website. Getting SSL_ERROR_NO_CYPHER_OVERLAP error after activating Cloudflare


#1

Hello everyone

We added our website to cloudflare and sterted getting:

Secure Connection Failed
An error occurred during a connection to www.******.com Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP

In my Cloadflare dashboard I get this:

Encrypt communication to and from your website using SSL.

It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.

Note: SSL certificate issuance may take up to 24 hours.

Status: Active Certificate

It says its active but i cannot open it from anywhere. We got a Let’s Encrypt certificate from our hosting company for free. Also we are using the Free account here in Cloudflare.
So is that normal and should We wait 24 hours or should We try to delete and add the website again?
Also we filled a ticket but there is still no answer. Request #1437088.
It is a working site, so what should we do guys ?


#2

Not normal. Hopefully Support will get back to you soon.


#3

Ah I hope they answer soon. It’s Last activity its changing but no answer.


#4

I’m doing some checking, but in the meantime I tried going directly to your origin IP and I got an SSL error. Have you checked for any redirects set at your server level?


#5

@ryan

Hello and thanks for the answer. We are not aware of any redirect set at server level, but again we are not a professionals, so can you tell us where to check for such kind of redirects? Should we write to our hosting company support about those redirects. We spoke with them and they said that we should contact you about this issue because the certificate that they provide “Let’s Encript” was working from Hosting to Cloudflare, but there was no from Cloudflare to user.


#6

We talked with our hosting company and they said that there are no redirects. Also he said that when he tries enter the site he gets “ERR_SSL_VERSION_OR_CIPHER_MISMATCH”. We issued a ticket but we got no answer to it more than 24 hours. Ticket number: 1437088 .


#7

I’m not sure what the exact issue was, but one of the support wizards resolved it. I’ll try to get more detail and respond with that on your ticket.

But I’m the meantime you should be good to go!


#8

@ryan

Hey Ryan

Not sure who really did it because I deleted the site and re-enter it. And after that the site was working.
But anyway thanks.


#9

me too have to show this error


#10

@ryan here is my ticket #1444744 i have been waiting more than 3 days for my SSL to get activated, can you please have a look at it, thanks


#11

@ryan we have some problem too
Request #1444783
thn for helping


#12

Looks like support already took care of it :yay:


#13

Same goes for you as well! Thanks for everyones patience. :partyparrot:


#14

Hi! Have been working with cloudflare for a while now. Suddenly today we get the error:

Secure Connection Failed

An error occurred during a connection to www.lakesregion.org. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP

Here’s the strange bit. This only happens on Comcast ISP customers. I have been on chats all day with bluehost and Comcast and they both tell me that I need a SSL 3.0 certificate. Apparently comodo is the reputable SSL 3.0 provider, and both recommend them. I get on a chat with their tech guy, and he tells me he can’t trace any SSL certificate at all.

This is a HUGE mess… anyone have ANY thoughts?


#15

Keep an eye on this thread…it may be the same issue:


#16

Hi Guys,

We are getting the same error on our website recently. We have been working fine for over a year. This just started happening few days ago.

WPEngine is hosting our site and for now we have to disable cloudflare entirely.

Thanks.
-Jay