Cannot make CloudFlare work — Website not available anymore

Hi guys,

I am trying to set up Cloudflare for the first time. Luckily I chose a domain that is not critical — it cannot be reached anymore after I made the requested DNS changes. There’s a pretty good chance that I did things wrong though.

The domain is wettbretter.de. The Cloudflare dashboard tells me: “Pending Nameserver Update”. The Cloudflare overview for this domain looks like this:

What I did
24.10.2022: I added the two entries to my DNS and deleted the “old” NS records. The domain could not be resolved.

25.10.2022: I changed back to the old settings and the website can still not be reached.

I guess I need a hint what I did wrong.

Cheers, Frank

You need to change the Name Servers to the ones given by Cloudflare, once that’s done we can see if something is wrong. This can take 24 hours.
They are now on the following name servers:

dig ns wettbretter.de +short
cns1.alfahosting.info.
cns3.alfahosting.info.
cns2.alfahosting.info.

and need to be changed to the ones listed at Cloudflare.

Hi milk,

that’s what I thought I did — and I checked 24 hours later.

I will make the changes again. In the DNS settings I have to enter a Primary Nameserver. Which one would this be — hank oder ziggy?

Cheers, Frank

denic says you have not updated the WHOIS records for your domain. You can’t set name servers in a domain’s own DNS.

1 Like

It seems you were able to change the NS now:

dig wettbretter.de ns +short
hank.ns.cloudflare.com.
ziggy.ns.cloudflare.com.

Does it show up in Cloudflare now?

It still looks it’s going through the old name servers:

% dig wettbretter.de ns +trace | grep wettbretter.de
; <<>> DiG 9.10.6 <<>> wettbretter.de ns +trace
wettbretter.de.		86400	IN	NS	cns1.alfahosting.info.
wettbretter.de.		86400	IN	NS	cns2.alfahosting.info.
wettbretter.de.		86400	IN	NS	cns3.alfahosting.info.
wettbretter.de.		300	IN	NS	hank.ns.cloudflare.com.
wettbretter.de.		300	IN	NS	ziggy.ns.cloudflare.com.

Ah yeah, that’s true:

dig wettbretter.de @a.nic.de
...
;; AUTHORITY SECTION:
wettbretter.de.         86400   IN      NS      cns1.alfahosting.info.
wettbretter.de.         86400   IN      NS      cns2.alfahosting.info.
wettbretter.de.         86400   IN      NS      cns3.alfahosting.info.
...

@Frank_J where are you editing your nameservers? You need to do it at the domain registrar level, not the hosting of the domain (who probably have their own nameservers).

Hi sdayman and milk,

thanks for following my problem.

As you probably can tell I am no DNS expert. So I feel like being a baker repairing a spaceship. :frowning:

My provider (Alfahosting in Germany) offers a DNS tool (AlfaDNS). I can create and edit nameservers and administrate domains.

I removed the nameservers that my provider runs (cns.alfahosting.info). There’s an extra entry where I have to name a “Primary Nameserver” (which is cns1.alfahosting.info. right now). I can only edit this entry. What to do with this?

The website wettbretter.de is still not reachable.

Cheers, Frank

You need to go into the domain administration and edit the primary and secondary nameservers there.

I found the following support articles for Alfahosting on changing the nameservers:

https://alfahosting.de/antworten-auf-ihre-fragen/?cid=62&id=227#a227

https://alfahosting.de/antworten-auf-ihre-fragen/?cid=11&id=588#a588

Hi milk,

this could have been the missing thing: I completely forgot that there’s nameserver entries in the domain aministration. Instead I thought that only the DNS records would be relevant.

So now I changed the Domain Nameservers 1 and 2 to hank and ziggy. The wettbretter.de domain now is shown as active in the Cloudflare panel.

I will probably take some hours before I can proceed, right?

Cheers, Frank

Hello,

As you have just said,

You can start configuring Cloudflare in it. I am able to see that the nameservers have successfully updated:

$ whois wettbretter.de
[...]
Domain: wettbretter.de
Nserver: hank.ns.cloudflare.com
Nserver: ziggy.ns.cloudflare.com
Status: connect
Changed: 2022-10-30T10:03:21+01:00

Be aware that it may take up to 24-48h before the changes are noticed worldwide.

Hope it helps!

So now that the DNS and Domain settings seem to be correct: Are there any required Cloudflare settings that I missed and that could prevent the website to be online?

Cheers, Frank

Do you have DNS records for wettbretter.de and www?

1 Like

Hi sdayman,

not for www. As a web address this looks so 1990s that I don’t use it.

Cheers, Frank

The website is still not shown. The DNS changes are now online for more than 48 hours.

There must be a problem that I do not recognize. Any ideas?

Please post a screenshot of your DNS records here. It’s ok to black out the IP addresses.

Here’s a screenshot of the DNS settings:

Here’s the Domainrobot entry:

You need to configure your DNS in Cloudflare, not the hosting provider.

1 Like