Cannot login states too many re-directs

I changed my domain name some time ago from to HostGator indicates everything has transferred but I wonder. After coming back here to Cloudflare…I now CANNOT log into my WordPress site.
When I try to log into - the message is - too many redirects. I have already been to HostGator. This began immediately after I CHANGED THE NAMESERVERS TO Cloudflare. **EMPHASIZING only with caps.

I changed to WP Fastest Cache recently and deleted some other plugins trying to make the site faster…NOTHING IS WORKING NOW

Thank you for your help, please.
Linda Todd

Make sure you selected Full Strict as encryption mode.

1 Like

To expand a bit more on this (Sandro’s advice I think is spot on):

Visit the SSL dashboard and check your SSL encryption mode setting - it should be to be set to Full (Strict).

If you encounter an error when loading your website with Full (Strict), visit SSL/TLS > Origin Server and follow our deploy an origin CA certificate guide to install a valid certificate on your server - this will allow you to use Full (Strict).

If you cannot install a valid certificate on your origin, you can downgrade your SSL encryption mode to Full as an alternative. As a last resort you can choose Flexible however if you continue to see redirect loops you will need to fix that issue at your origin server. Read our Too Many Redirects guide for further information.

That’s probably what the OP currently has and that’s precisely the issue, as that insecure, legacy setting broke the site unfortunately.

The server is properly configured, so it should load fine once the correct encryption mode is set up.

1 Like

Thank you so much…fixed it and good to go. WOW very helpful as I did not have a clue what to do.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.