Cannot log in to Dashboard

I cannot sign in to my account (which made me have to go register an alt account in order to get help here).

I’ve tried my usual password as it has always worked right from my password manager, but I get “Email address/password do not match”.

I then did a password reset, and picked a new password that passed all the checks and seems to have been saved successfully.

But when I then try my new password - still in my clipboard - and verified by comparing with my own eyes from my password manager - I still get the same error.

I’ve accepted all cookies, I’ve tried both Firefox and Chrome, but neither works.
I have an API key that I believe should still be active and working. Could I use that to regain access somehow, perhaps by proving my identity? (I get that this is “just” community support, though. Probably won’t help me as I also won’t be sharing my API keys with anyone not verified to be a Cloudflare employee; preferably not even there; but I could use the key to change DNS entries to respond to a challenge, for example.)

  • I used 2FA, but I won’t get prompted for my 2FA token. I just get a CAPTCHA after a few failed log in attempts.
  • I’m in the EU; could that be related?
  • I’ve disabled tracking protection and ad blockers on Cloudflare already, and on Chrome I have nothing like that installed.
  • I don’t think my account has been disabled as I can still access my site - for now.
  • I tried this last night and this evening, same issue both times.

Does anyone have any pointers? Things I could look for? I really think this must be on me, because if there was a login bug I would expect the whole internet to have noticed now a few hours later.

Ah, would you look at that! I tried yet another password reset, and this time it seems to have worked. Now I gained access again.

(I even used the same password as what I changed to previously, so the password must’ve been fine.)

I don’t know where I fat-fingered this so many times, but if you get this issue on your end - trust your gut and realize that you probably made a mistake (even if it was multiple times). Retry until it works, I guess.

Sorry for bothering you all! Have a lovely day!