Cannot get to sites through Reeder on macOS

I read Powerline blogs through Reeder ( on macOS and iOS, an RSS reader. On iOS it works.

On macOS, I can get to the entries themselves, but when attempting to view links on the blogs, either from the RSS feed or the embedded browser, clicks send me to the needs to review the security of your connection before proceeding” page, with a checkbox for human verification, but clicking on it results in a loop.

This works from Safari on the same machine, at the same time, and last time I used a macOS machine, it worked, as well, probably only a few days ago.

On my most recent attempt, I tried clicking on the checkbox and blue human verification button at least 10 times but never got through. At the bottom of the page is Ray ID: 79b7ac2669561883.

Hi there,
Could you please contact the owner of the website you’re trying to access here?
They can then get in touch with our support team if needed.

I have already done so, but reached out here, as well. Note that I wasn’t clear in my original message, but only links from are affected: even other sites protected by Cloudflare seem to work.