Cannot get Subdomain to work

Recently registered for cloud flare and moved over one of my domains. The root domain seems to be working fine. But I can’t get any of the subdomains to work.

After moving the root domain across to cloud flare by adding the cloud flare babe servers to my domain hosting account (with 1&1) the sub domains came across also. All the sub domains are set up with A records pointing to a specific up address. When I check the DNS resolution in dnschecker they all resolve to the same ip addresses (I don’t recognise them so assume they are cloud flare).

However - when I try and access any of the sub domains through a browser I just get a can’t find page error like it can’t resolve the DNS. I tried changing one of the sub domains to CNAME rather than A record and still get same issue.

Root domain is villamastr.com
Sub domain demo.villamastr.com

Apologies if this is covered in help pages but I’ve read them and still can’t work out the issue.

I’m a newbie. Can anybody provide me any guidance?

Thanks
E

resolves well, but your’re redirecting to www.demo which does not have a DNS record.

~/ curl -I demo.villamastr.com
HTTP/1.1 301 Moved Permanently
Date: Fri, 05 Jun 2020 07:32:27 GMT
Content-Type: text/html
Connection: keep-alive
Set-Cookie: __cfduid=db8a91af9c0cd89e94a55c47fa9431df61591342347; expires=Sun, 05-Jul-20 07:32:27 GMT; path=/; domain=.villamastr.com; HttpOnly; SameSite=Lax
Location: https://www.demo.villamastr.com/
CF-Cache-Status: DYNAMIC
cf-request-id: 0324fe4e800000dbfbbb8c4200000001
Server: cloudflare
CF-RAY: 59e8332a68f3dbfb-LHR

~/ nslookup www.demo.villamastr.com
Server: 127.0.0.53
Address: 127.0.0.53#53

** server can’t find www.demo.villamastr.com: NXDOMAIN

Hi Mark. Thanks for the time to look at this. there was a redirect applied at the server level in plesk. I removed this and now works.

help much appreciated

thanks

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.