Cannot get response from external service API

Since a few days I am not able to receive reponse from an external service API that I used for months without issues. I contacted the service administrator and we tried to understand what was the issue. From the service side there was no problem: my request is received but I cannot receive the API response.Given that I did not make any changes to my site lately, we supposed the issue is due to cloudflare. In fact the same issue occurred for other 2 different services: they worked fine for months, then I could not be able to receive their API responses overnight.

I searched for someone here having a similar issue and the following is the only topic discussing an issue similar to mine:

However, I already tried the solutions discussed in the above topic (I inserted an ‘allow’ IP access rule for the service IP), but nothing changed. Before trying with this solution, I also tried to disable every firewall rule and every IP access rule. I could not receive the API response even in that case.

Is there anything else I can try to solve this issue?
Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.