Cannot get HTTPS working

I’m trying to get HTTPS working, but I always get Bad Gateway

I’ve tried jellyfin (setting up tunnel as HTTPS and routing to jellyfin’s https port)
I’ve tried deluge-web (setting up tunnel as HTTPS, routing to default port, and creating cloudflare certs and keys for SSL)

Both work “perfectly” when trying over http, but neither works with https. with and without TLS verify.

Is there maybe a way in which the outside world connects to cloudflare server via https, cloudflare tunnels onto my server and connects to cloudflared, and cloudflared connects to application via http? I don’t really need https on my local network, but just don’t want it open to the world.

Again, my fault. For some reason, when I typed in the address for the HTTP configured version into firefox it refused to use https, but manually typing in the https part, the http configured ones work perfectly.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.