Cannot get Access working to web Application

I am playing around with Cloudflare and I am attempting to protect a web application (self hosted) with Cloudflare Zero Trust access functionality. Before I enabled this, the website worked fine publicly.

I have been able to both setup Google and Azure AD as sign-on methods, and the tests there work properly. But I cannot get the website to work at all. It is currently connected to Cloudflare via a tunnel and the tunnel reports that it is working properly.

I tried to setup a very basic rule for access- only allowing my personal email account and my work domain to be able to access. But it will not work. Even when I deleted the rules, it will not work, it just 404s.

It WAS working when I had normal A DNS entries pointing to the site, although I believe the documentation said I needed to create a Cloudflare tunnel to use the Access restrictions.

Since i’ve deleted the tunnel and the respective DNS entries, it again works fine.

What am I doing wrong here? I’ve been following all the guides.

Sounds like there isn’t anything related to Access that is an issue here, but rather an issue with your tunnel configuration. Without knowing the details of that configuration, I’d recommend you can connect from the machine running the hostname to whatever host/ip you have configured in your tunnel YML exactly as it’s configured using curl to verify you’re getting a proper response from the origin and look at tunnel logging to determine what/if anything is being logged there as well.

Thank you, I will give that a shot. You think that’s worth investigating even when Cloudflare says my tunnel is green / good to go?