Cannot get a CNAME or Page Rule to work

No matter what we do, we cannot get our “www” CNAME or “Forwarding URL” Page Rule to work. It always goes to clickfunnels.com instead of where it is supposed to go.

We also tried deleting the “www” CNAME record and creating an A Record for it. That doesn’t work either. :frowning:

We even tried deleting the domain from Cloudflare and re-adding it.

Oh, and we tried to submit a support ticket to rebuild the zone (because we believe something is “stuck” behind the scenes). However, since we are on a free account, no support was offered.

Any ideas would be greatly appreciated!

Oh, the support ticket said don’t forget to include “Need a zone rebuilt” in the details. :slight_smile:

So https://kaizenergy.net/ goes to, well, https://kaizenergy.net/ and I guess you want https://www.kaizenergy.net/ to redirect to https://kaizenergy.net/ but instead it’s getting sent to https://www.clickfunnels.com/

Have you ever used https://www.clickfunnels.com/ or their solutions in the past?

Do you have a screenshot of the Page Rule that you created?

@KianNH yes, ClickFunnels was used in the past. However, the domain has been deleted there now.

Here is the screenshot of the page rule. Unfortunately, I was not allowed to post this in my original posts. :person_shrugging:

It’s possible that they were using SSL for SaaS - which ‘overrules’ your settings - and at a glance, that’s what I’m expecting.

C:\Users\K>curl -sSI https://www.kaizenergy.net/
HTTP/1.1 403 Forbidden
Date: Thu, 05 May 2022 01:57:48 GMT
Content-Type: text/plain; charset=UTF-8
Content-Length: 16
Connection: keep-alive
X-Frame-Options: SAMEORIGIN
Referrer-Policy: same-origin
Cache-Control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Expires: Thu, 01 Jan 1970 00:00:01 GMT
Expect-CT: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Set-Cookie: __cf_bm=SBgknh_9ad21xOfeLfFhK4WRbdI4_jQmRJ5lk2XirzI-1651715868-0-ASQOboiHKwCT1i4RkzPQ1vUoY5EGk/QacaliHb2nBrPM/Pyt3BgQhm1w7BudNWx2taEnMHkitrEzBmW+RxeoSgt/nbekS8nwer5d/2xEX77K; path=/; expires=Thu, 05-May-22 02:27:48 GMT; domain=.www.kaizenergy.net; HttpOnly; Secure; SameSite=None
Server: cloudflare
CF-RAY: 7065de103836773e-LHR


C:\Users\K>curl -sSI https://www.clickfunnels.com/
HTTP/1.1 403 Forbidden
Date: Thu, 05 May 2022 01:57:58 GMT
Content-Type: text/plain; charset=UTF-8
Content-Length: 16
Connection: keep-alive
X-Frame-Options: SAMEORIGIN
Referrer-Policy: same-origin
Cache-Control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Expires: Thu, 01 Jan 1970 00:00:01 GMT
Expect-CT: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Set-Cookie: __cf_bm=fDl6yz2wWTvyqERY54_HPYyEbp8a2wp9chxZbVDL8nY-1651715878-0-AVBys+a4JbS5rGbleYomkMGs/3B+8Bzg5od4Ug7rWctwFuq1Q5oGheKYDPVPwVh/TLKC0arQilyoIrV9vcVpeho7tdx6i46s1xkc/8QbmLtK; path=/; expires=Thu, 05-May-22 02:27:58 GMT; domain=.clickfunnels.com; HttpOnly; Secure; SameSite=None
Server: cloudflare
CF-RAY: 7065de4dbd127792-LHR

The response headers are pretty much identical - but, short of someone on the Cloudflare support team being able to check on their end, the only way to find that out is contacting ClickFunnels.

In the event ClickFunnels are using SSL for SaaS, it sounds like the domain might not have been properly removed from their setup and therefore their setup is still trumping yours. Do you have a support ticket open with them?

There is a support ticket open with ClickFunnels, but so far no real help/progress on the issue as they believe the issue is in Cloudflare. Looks like we may have to upgrade to Cloudflare Pro just to get support on this issue. :frowning:

Looks like removing the domain and re-adding it actually worked in the long run. It just needed time to propagate (maybe?). It is now working.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.