Cannot disable domain redirection

Hello,

I can see that for my Cloudflare free domain there is currently redirection taking place to another URL. This only happens to the root domain (top-level folder) and not to any subfolders. I have double checked all page rules and redirection rules in Cloudflare. I have spoken to my hoster and they double checked no redirection is active on their end. Also i have integrated cloudflare to ezoic and their support confirmed that there is no redirection in place. Can you please provide a thorough list of sections to check inside my Cloudflare account configuration to ensure that the redirection is removed?

What is the domain?

1 Like

Trace should do that:

1 Like

Hello,

I ran the Cloudflare trace as suggested. I am providing below json export of the trace results.

{“trace”:[{“step_name”:“http_request_sanitize”,“type”:“phase”,“matched”:true,“public_name”:“URL Normalization”,“trace”:[{“step_name”:“6639e3304d484da3b6e095e4560215c6”,“type”:“ruleset”,“matched”:true,“description”:“ruleset for controlling url normalization”,“name”:“Entrypoint for url normalization ruleset”,“kind”:“zone”,“trace”:[{“step_name”:“46dc5532d4884067a6b031d61049729c”,“type”:“rule”,“matched”:true,“action_parameter”:{“id”:“70339d97bdb34195bbf054b1ebe81f76”,“version”:“latest”,“overrides”:{“rules”:[{“id”:“78723a9e0c7c4c6dbec5684cb766231d”,“enabled”:false},{“id”:“b232b534beea4e00a21dcbb7a8a545e9”,“enabled”:true},{“id”:“20e18610e4a048d6b87430b3cb2d89a3”,“enabled”:false},{“id”:“60444c0705d4438799584a15cca2cb7d”,“enabled”:false}]}},“expression”:“true”,“action”:“execute”,“trace”:[{“step_name”:“70339d97bdb34195bbf054b1ebe81f76”,“type”:“ruleset”,“matched”:true,“description”:“Created by the Cloudflare security team, this ruleset provides normalization on the URL path”,“name”:“Cloudflare Normalization Ruleset”,“kind”:“managed”,“trace”:[{“step_name”:“b232b534beea4e00a21dcbb7a8a545e9”,“type”:“rule”,“matched”:true,“action_parameter”:{“uri”:{“path”:{“expression”:“normalize_url_path(raw.http.request.uri.path)”},“origin”:true}},“description”:“Normalization on the URL path, propagating it to the origin “,“action”:“rewrite”}]}]}]}],“zoneName”:”[my root DNS domain]”},{“step_name”:“file_upload_scan”,“type”:“product”,“matched”:false,“public_name”:“Uploaded Content Scanning”,“zoneName”:“[my root DNS domain]”},{“step_name”:“api_shield”,“type”:“product”,“matched”:false,“public_name”:“API Shield”,“zoneName”:“[my root DNS domain]”},{“step_name”:“http_request_firewall_managed”,“type”:“phase”,“matched”:false,“public_name”:“WAF Managed Rules”,“trace”:[{“step_name”:“50fcbc0d98674f22b9d3ac01ba0e2f6b”,“type”:“ruleset”,“matched”:false,“name”:“default”,“kind”:“zone”}],“zoneName”:“[my root DNS domain]”},{“step_name”:“request_managed_headers”,“type”:“product”,“matched”:false,“managed_headers”:[{“id”:“add_client_certificate_headers”,“enabled”:false},{“id”:“add_visitor_location_headers”,“enabled”:false},{“id”:“remove_visitor_ip_headers”,“enabled”:false}],“zoneName”:“[my root DNS domain]”},{“step_name”:“response_managed_headers”,“type”:“product”,“matched”:false,“managed_headers”:[{“id”:“remove_x-powered-by_header”,“enabled”:false},{“id”:“add_security_headers”,“enabled”:false}],“zoneName”:“[my root DNS domain]”}],“status_code”:301}


The end result is:
HTTP Status Code:
301 Moved Permanently

However i do not recall having setup a redirection rule in Cloudflare and i checked the redirection and page rule section and is empty.

Do you have any ideas?

Not without this critical information.

When you post console output, it is a lot easier to read if you use </> Preformatted text on those parts (and only those parts). For multiple lines or is easiest to place three backticks ``` on the line above and below the text to format.

This:
```
When your console output is formatted,
it is much easier to read.
```

Becomes:

When your console output is formatted,
it is much easier to read. 

From the trace, it sure looks like the redirect is not coming from Cloudflare. Too bad the trace doesn’t return all the response headers from the origin server.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.