Cannot connect to website using as cannot SSL

I have been trying to connect zapier to our magento2 store which uses Cloudflare. I appears that zapier does not like Cloudflares sni and we get this message even after disabling the SSL check on zapier:

SSLError: hostname ‘’ doesn’t match u’

I do have our own SSL certificate, but we are unsure about disabling the SSL on Cloudflare and it is not clear how this would work.
I was also wondering if there was a way of bypassing the Cloudflare firewall, so zapier could connect directly to our site.
Any help would be appreciated.

I’d contact that service provider as they’d need to sort that out. Apparently the dont support SNI. You could either disable Cloudflare’s proxy and have requests go directly to your server or purchase a $5/month dedicated certificate from Cloudflare.

It is not clear from the documentation if I can temporarily disable the SSL to test, and go back to to it later if it does not work.
The Cloudflare certificate would work for me, but we also need SSL for our email, and I am not sure the Cloudflare certificate would work for the email, so would en up needing to purchase two certificates. Or is there a way it would work for our email too?

What would disable TLS help you? Simply point the URL to HTTP, no need to disable TLS.

How would the Cloudflare certificate work for you if that provider does not support SNI and/or SAN, which is required by Cloudflare. Email is a completely different subject and not covered by Cloudflare anyhow.

What the URL in question?

This topic was automatically closed after 30 days. New replies are no longer allowed.