Cannot connect site's CloudFlare plugin to CloudFlare account

I had to deactivate my Wordpress site’s Cloudflare plugin while troubleshooting what turned out to be issues related to Dreamhost’s Proxy Cache Purge plugin.

Upon reactivating the Cloudflare plugin, I attempted to log into my Cloudflare account through the plugin using my email address and the Cloudflare WordPress API Token I generated. Logging into the plugin seemed to succeed, but a red bar temporarily appeared at the bottom of my browser window with the error “! Not Found”. The plugin doesn’t allow me to use any paid Cloudflare features even though I have a paid plan, and clicking the Analytics tab just produces an endless progress wheel, so it seems like the plugin isn’t actually connected to my Cloudflare account.

I’ve tried clearing my site’s cache from the Cloudflare site, but that did not affect the issue. Any help would be appreciated!

I know API Tokens are the best way to connect, but have you tried the Global API Key?

Having some issues with the Cloudflare Wordpress plugin…

It’s lost the ability to purge the cache – either automatically with new posts etc, or manually via the ‘purge’ button in the plugin settings.

I’m also getting a red ‘not found’ error that flashes up at the bottom of the plugin screen for a few seconds – but beyond that, everything looks normal.

Judging by the discussion on the plugin page on Wordpress.org, a few others are having the same issues!

Haven’t changed anything to do with Cloudflare, Wordpress or my hosting environment in the last few days, so seems to be spontaneous.

I’m guessing it’s an API-related error based on all of the above – and I notice another topic here with issues connecting the API to the plugin!

Any help appreciated! :slight_smile:

We are currently receiving this error inside the cloudflare wordpress plugin (Not found):

We don’t quite know what the problem is, we upgraded to 4.2.0.

1 Like

As there are now three cases of this, I suggest you open a ticket and let Support know. Please post the ticket number so the mods can keep an eye on it. @amayorga is around and will probably also take a look.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

This is the issue: Zone Analytics deprecated · Issue #378 · cloudflare/Cloudflare-WordPress · GitHub

Old Zone analytics were deprecated, so the API call to pull analytics fails. That is the error it displays. The plugin is otherwise fine

1 Like

As a workaround you can access Analytics directly in https://dash.cloudflare.com while the issue is resolved.

1 Like

Same issue with the Global API Key, unfortunately. I’ll contact support as you suggested in your other comment - thank you!

The bigger issue from my point of view is the lack of automatic cache purging whenever a Wordpress post is created or updated.

For a site where news is regularly added every 10-20 minutes or so, it’s not ideal (to say the least!) to have to purge the cache from the Cloudflare dashboard any time there’s a change.

Logged with support in ticket ** 2101561** so fingers crossed this gets resolved soon!

Having the same issue here.
It seems the CloudFlare Cache is not purged anymore, if a new post goes online, and the users can’t see the new content.
Worked fine until March 1st.

Please fix the plugin!

[05-Mar-2021 10:17:54 UTC] [Cloudflare] ERROR: Not Found
[05-Mar-2021 10:19:51 UTC] PHP Warning: file_get_contents(/home/xxx/public_html/wp-content/plugins/cloudflare/src/WordPress/composer.json): Failed to open stream: No such file or directory in /home/xxx/public_html/wp-content/plugins/cloudflare/src/WordPress/PluginActions.php on line 216
[05-Mar-2021 10:19:51 UTC] PHP Warning: Trying to access array offset on value of type null in /home/xxx/public_html/wp-content/plugins/cloudflare/src/WordPress/PluginActions.php on line 182
[05-Mar-2021 10:19:53 UTC] [Cloudflare] ERROR: [CLIENT API] Array
(
[type] => request
[path] => https://api.cloudflare.com/client/v4/zones/xxx/analytics/dashboard?since=-43200&action=cloudflare_proxy
[timeout] => 30
[method] => GET
[headers] => Array
(
[Content-Type] => application/json
[X-Auth-Email] => [email protected]
[X-Auth-Key] => xxx
)

)

[05-Mar-2021 10:19:53 UTC] [Cloudflare] ERROR: [CLIENT API] Array
(
[type] => response
[reason] => Not Found
[code] => 404
)

[05-Mar-2021 10:19:53 UTC] [Cloudflare] ERROR: Not Found

the issue is unrelated to the CF plugin and is already fixed.

1 Like

Issue still exists on our end… when you go to the WP plugin a red bar is displayed at the bottom with an exclamation mark stating “Not Found”

This thread has two separate issues being discussed:

  1. cache purge issues. This was identified and has since been resolved this morning (US time)

  2. Red bar showing up in the plugin. This is due to Zone Analytics deprecated · Issue #378 · cloudflare/Cloudflare-WordPress · GitHub which will be fixed with the next release of the plugin due to be released today.

2 Likes

plugin v4.2.1 was just released which should fix #2

1 Like

Now;

Line 182 : $config[‘version’] = $this->composer[‘version’];
Line 216 : $this->composer = json_decode(file_get_contents(dirname(FILE) . ‘/composer.json’), true);

[05-Mar-2021 20:35:42 UTC] PHP Warning:  file_get_contents(/home/xxx/public_html/wp-content/plugins/cloudflare/src/WordPress/composer.json): Failed to open stream: No such file or directory in /home/xxx/public_html/wp-content/plugins/cloudflare/src/WordPress/PluginActions.php on line 216
[05-Mar-2021 20:35:42 UTC] PHP Warning:  Trying to access array offset on value of type null in /home/xxx/public_html/wp-content/plugins/cloudflare/src/WordPress/PluginActions.php on line 182

@Ragnar you might be seeing the same thing as here: Bug: Warning: file_get_contents of composer.json · Issue #380 · cloudflare/Cloudflare-WordPress · GitHub in either case this is a different issue. Please provide more details on github, so we can investigate.

When I enter the extension page, it creates the log file in the wp admin folder containing the above errors. It does not show the version of the extension on the extension page.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.