Cannot connect Cloudflare Pages to Github

Whenever I connect Cloudflare Pages to Github, when GitHub redirects me back to Cloudflare, I get this error.

User is not authorized for provided Installation ID (Code: 8000010)

From the message it seems like the authentication failed. Did you make sure the permissions wanted were allowed and you gave access to at least 1 repository?

I’d suggest trying to authenticate again. If it continues to fail let me know. I can ask the team what this is about

I suggest you join the Discord, the team and lots of other users are there who can also help. The invite is: Cloudflare Workers

I’m having the exact same problem with Cloudflare pages.

I tried again by removing the Cloudflare Pages app from Github and adding it again (both normally and in incognito) and still the same error. Initially I gave it access to only my site repo but on retry i gave it access to all repos.

Retried again. Same result too.

The error is also so extremely unhelpful.

Also same error here… have tried many times with different accounts etc to no avail.

Happening on my account also, tried many times on more than one account.

Having same issue here.
User is not authorized for provided Installation ID (Code: 8000010)

Also have the exact same error here when redirected from github.

Hey, this is a known issue. The fix has been done and will be rolled out soon. I will update here when I have heard the rollout starting/finishing

You can stay more up to date on Discord: Cloudflare Workers

Edit: The fix is rolled out and this issue should be gone :slight_smile:

1 Like

Problem solved!!!
Thank you!!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.