Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP


#1

Hi,

i am new here. Can anyone help me how to solve this issue?


Getting Timing Out error for Flexible SSL
#2

As you probably read in the other thread you posted in, you probably don’t have a working Cloudflare SSL certificate.


#3

But the status of my website is active and i’ve set the ssl to flexible. What should i do?


#4

Maybe a similar problem… my SSL status are:

I’m looking how to fix it.


#5

I haven’t seen that error before. It’s clearly not working. login to Cloudflare and then contact Cloudflare Support.


#6

Thanks, I already send an email, but no reply yet.
I will keep here updated.

Already tried turn SSL Off/On but same error instantly


#7

You can also go to the bottom of that page and try “Disable Universal SSL” and wait a few minutes before clicking that button again to “Enable Universal SSL”


#8

Amazing, that work.

My steps:
-Turn SSL OFF
-Wait 3 minutes
-Disable Universal SSL
-Wait 5 minutes
-Enable Universal SSL
-Wait 5 minutes
-Turn SSL On (Flexible)
-Wait ± 15 minutes
-Activeted Certificate


Keywords (to help people to find)
Certificate Timing Out workaround, Cloudflare certificate timing out


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.