Cannot clip video

I tried clipping a video, the clip appears as queued on my video list, then goes straight to “Error” status after a minute or two, and the error is this:

“status”: {
“state”: “error”,
“step”: “clipping”,
“errorReasonCode”: “ERR_UNKNOWN”,
“errorReasonText”: “The video failed to be encoded due to an unknown cause.”

The clip request doesn’t contain any special feature, just the source uid, start seconds and end seconds. I tried changing the start and end to 0-3600 (1 hour) and I get the same error. The source video is really long, like 4 days long, there could be issues with that? The thing is I want to clip it exactly because I want to remove this awfully long 4 days video… and I want to avoid having to download it all, clip the hour or so that I need and then reupload.
Anyone experiencing the same issue?


Hi @andrea5 , sorry to hear you’re running into this. Can you confirm if this is a VOD video or a live recording?

It’s a live recording. Sorry I was sure I did say that in the post but apparently I forgot :smiley:

Ah, unfortunately we haven’t added support for clipping live recordings yet. Small note on doc about this here:

This is something we’re actively discussing though and will follow-up on this thread when it’s implemented. Sorry for the inconvenience!

If you want a simple solution you can run yourself, you can create a download on Stream and clip it locally using ffmpeg.

ffmpeg -i input.mp4 -ss 00:05:20 -t 00:10:00 -c:v copy -c:a copy output1.mp4
-i input.mp4: Specifies the input video file.
-ss 00:05:20: Sets the start time of the output video at 5 minutes and 20 seconds into the input video.
-t 00:10:00: Sets the duration of the output video to 10 minutes.
-c:v copy -c:a copy: Copies the video and audio codecs from the input video without re-encoding.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.