Cannot browse localhost after disabling WARP app

Sometimes I use “Cloudflare WARP” app in my MacBook. If I enable this app once and disable it, my http://localhost doesn’t work until I restart my laptop.

Here is the error message:

This site can’t be reached

The webpage at http://localhost:3000/ might be temporarily down or it may have moved permanently to a new web address.


Screen Shot 2021-08-07 at 8.02.16 AM

1 Like

I am having this same issue too on my macbook

Same issue today after a reboot.
Without any other changes apart from starting or stopping Cloudflare Warp, I can either access my localhost with it enabled, or not access localhost - either by toggling it off, or even quitting the app altogether. OSX 10.15.7
A reboot just reloads the app so it works then, but this anomaly has also made the Mac invisible to other devices on the network, like the Apple TV which is pretty inconvenient. Going to try uninstall and see if that helps :frowning:

Update - uninstalling it is the only way to fix the issue - not an ideal solution!

I’m having same problem. Here how I resolve it.

  1. Restart Warp.
  2. If (1) does not work. Don’t use loopback (localhost/ address. Try to got you LAN IP instead. eg: ifconfig en0 inet| grep 'inet '|awk '{print $2}'

I’ve been having the same issue and it’s been driving me crazy for a month! and i couldn’t figure out what was happening! after enabling and then disabling warp, my steam games wouldn’t launch because they couldn’t connect to local steam client, i couldn’t use ssh tunnels (i could connect successfully but couldn’t use the localhost:port !), Docker engine wouldn’t start, …
the only solution was to reboot the device, OR connect to only (without warp) and change the DNS protocol to TLS. this made everything back to normal but it’s still a rather big inconvenience!

Me too!! can’t start live server nor Jupiter without activating

Also been seeing the same issue. This causes applications like Notion to stop working since they use websockets that depend on localhost access.

Almost all developer applications that depend on localhost stop working the moment the tunnel is disabled. Only workaround is to restart Macbook.

Reddit thread with possible workaround:

sudo ifconfig lo0 -alias


yes that fixes it! thank you!!!

Bumping this thread.
This is affecting us heavily at fabriq.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.