Cannot add users to Page access Policy due to no domain

We are only using the Pages feature of Cloudflare for our application.

I’m trying to add a developer to the access policy for the page so that they can do some testing, however it won’t let me save them to the account as it’s missing a required field on the application (domain).

I can’t add the domain as it says isn’t a zone associated with the account. This is because we do not use Cloudflare DNS for the domain - this is managed by our hosting company.

Only the subdomain, action.small99, is used and this is all handled by the Cloudflare Pages.

I cannot raise a ticket with support, because I don’t have a paid account. I cannot add a paid account, because we are not using Cloudflare for domain / webhosting.

I would like to add a user to the access policy for a page.

How can I do this, without adding a domain to the account? We are using Pages default domains


You will need to give them access to Cloudflare Workers.

Cloudflare Workers Admin -
Can edit Cloudflare Workers and Pages.

Thanks. I’ve just tried that however still get the following message when adding someone to the Access Policy:

Error configuring your application: access.api.error.invalid_request: domain or self_hosted_domains must be set

As we are using Pages, we have no domains set.

We are using Pages default domains .

You should be able to add users to access policy for a with these steps:

Thanks. I’ve followed those steps, however it still does not work.
On step 7 of that, there is no subdomain wildcard present to delete. I cannot save the settings page because no domain is selected. I cannot add as a domain, because it is not a domain in the account due to being a hosted solution.
I have added someone to the account with access to Cloudflare Workers, however they cannot access the Pages settings nor the Pages area, because they are not on the access policy.

Any ideas?

Please can you provide an update on the above? I still cannot add users to Pages access, even when following the steps provided.

The Zero Trust team is working on the issue, it should be allowed.