Cannot add punycode domain to Pages

Same here. Seems that Cloudflare does not support Punycode for :logo: Pages.

We do however there’s a known issue with a CA not supporting it. Can you please provide your pages.dev?

2 Likes

Hi @mysh, could you let us know which of your Pages projects you’e encountering this issue on? We’d be happy to help.

1 Like

Hey, I’m having issues with xn--80aggxivfi0i.xn--p1ai, though I successfully added it to the Websites.

Yet when I’m trying to add it to Pages it returns me An unknown error occured. Contact your account team or Cloudflare support: https://cfl.re/3WgEyrH. (Code: 8000000).

Some info:

  • Page that I’m trying to link it to: angliuster-ru.pages.dev
  • Domain that I’m trying to add: xn--80aggxivfi0i.xn--p1ai (англюстер.рф)

You should now be able to add the domains, please retry and confirm :slight_smile:

1 Like

Yep it works now! Could you provide more info on why I got this error? So that wandering souls will know what to do when such error occurs.

Your project is opted into using Google Trust Services as a CA, GTS doesn’t support IDN domains - CA · acmesh-official/acme.sh Wiki · GitHub

So we have to opt you out (so you’ll use LE instead which does)

1 Like

Thank you! Is it possible to opt-out without asking the support?

It is not but feel free to email me if needed in the future (walshy@)

Hopefully we don’t have this problem much longer, I was just OOO so not had the time to fix it yet.

1 Like

I also have a Pages project where I’m experiencing the same issue. Tried emailing on Friday but haven’t heard back. Please change CA for: site-mckorkort.pages[dot]dev

Sorry but am I supposed to create a duplicate topic for the same issue in order to get help with this? Thanks

Just opted you out of GTS. You should be good now.

1 Like

Hello! I’m having the same issue with 2 pages project.

Is it possible to communicate those in private/DM?

I have the same problem. Could you please opt out my pages also? meditationsvue.pages.dev

I’m out of office but set a reminder to ping someone on Monday.

I am facing a same problem with the domain **removed**.

An unknown error occured. Contact your account team or Cloudflare support: https://cfl.re/3WgEyrH. (Code: 8000000)

I have created a separate post, but have not received an updated in 4 days.

Leaving a reply here just-in-case. @Walshy @WalshyMVP

Hi, could you try that now?

I’ve replied there requesting the project url, thanks for your patience.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.