Cannot add new member error 1005

The issue first starts when I am in the add member page and insert the member’s email address. Even though it is a 100% valid address and the user can authenticate through zero trust to hosted apps, there’s an initial error of “Please enter a valid email address.” I am able to proceed though.

I select the appropriate domain to grant the r/o rights and continue to the summary. After confirming the settings and pressing the invite button I receive the error “Error when processing member: cannot add existing user that is participating in an incompatible authorization system(Code: 1005).” 1005 does not show up on Cloudflare’s list for troubleshooting (I tried adding the link but apparently that’s not allowed in this forum). Browsing the internet it appears 1005 has also been reserved for web access issues.

No clue what’s going on and how to traverse, would love to know if anyone has a solution.

And for full scope, I did just add two other members exactly the same way. There were similar errors along the way but the member invite was sent to those two. For this one case it will not complete.

May I just ask, are you trying to add a member under your CF account or maybe this is related to the Cloudflare Access / Zero Trust? :thinking:

Unfortunately, it knows to happen if for example the member email address somehow got to be on the suppression list due to an opt-out, or bounces.

However, have you tried writing to the Cloudflare Support about this? I’d suggest you to write a ticket to the Cloudflare support and share your ticket number here with us so we could escalate your issue.

You might be offered to switch to the new Customer Support Portal and create a ticket there.

cc

I am trying to add under the CF account. It’s quite confusing as I am successful with others adding the same exact way with the same exact permissions. Thanks for the tip on the suppression list, I’ll have to explore that.

Otherwise I did simultaneously open a ticket with CF support at the same time as posting this here - hoping to get the quickest resolution from whichever option.

@fritex I wanted to let you know I spoke with my Cloudflare rep and the issue was a result of using the newly GA Domain Scoped Roles - see https://cloudflare.tv/event/ea8JJLgR. Apparently there was a “left over entitlement” from when it was in Beta. They fixed things on the backend and I could process my member’s invite afterwards.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.