Cannot add Kajabi name server ! Help!

I am currently trying to set up Domain Name in KAJABI, but I cannot connect Custom Domain to KAJABI because I cannot change the DNS name server.
I would like to rewrite the name servers in DNS to the ones specified in KAJABI, but I have been unable to do so.
The main problem is that when I try to enter the custom nameservers specified by KAJABI, my custom domain is displayed right after I enter it. Also, when I try to delete my custom domain by editing it, the system does not accept it.
I have no idea what the heck is going on. Can someone please tell me how to add custom nameservers?

Custom Name servers are added at your registrar. If Cloudflare Registrar is your registrar, then the registrar’s Terms Of Service 6.1 prohibits changing name servers and you’d have to use a different registrar for your domain.

1 Like

postscript
The error message displayed at the bottom of the screen when I try to edit the custom nameservers is (code 1236).

Custom Name Servers (on Business/Enterprise plans) is really a vanity name server alias for the existing Cloudflare name servers. They can not point to external name servers.

1 Like

Mr. Sdayman.

Thank you for your advice.

I got my custom domain on CLoudflare, which is recommended by KAJABI. And now I am trying to register my custom domain in KAJABI.

According to KAJABI, the procedure for connection is as follows

Sign in to CloudFlare, Inc.
Go to the DNS settings for CloudFlare, Inc.
Remove the following nameservers:

 monika.ns.cloudflare.com
 norm.ns.cloudflare.com

Now, add these Kajabi nameservers:

 Now, add these Kajabi nameservers: jermaine.ns.cloudflare.com
 joyce.ns.cloudflare.com

According to the registrar’s Terms Of Service 6.1, I “can’t” do the above method as instructed by KAJABI?

Correct, if the domain is registered through Cloudflare’s Registrar service.

1 Like

Oh, my God!!!

Anyway, Thank you so much for your precise explanation.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.