Cannot add image transformations to images - 10000 error

For Workes & Pages, what is the name of the domain?

What is the error number?

10000

What is the error message?

  • TLSv1.2 (IN), TLS header, Supplemental data (23): {“success”:false,“errors”:[{“code”:10000,“message”:“Authentication error”}]}

What is the issue or error you’re encountering

Attempting to set transformations for images. I keep getting authentication errors

What steps have you taken to resolve the issue?

Used multiple versions of this script running thru chatgpt and gemini

What are the steps to reproduce the issue?

curl -X PATCH -v “https://api.cloudflare.com/client/v4/zones/XXXXXXXXXXXXXXXXXX/settings/transformations
-H “Authorization: Bearer YYYYYYYYYYYYYYYYYY”
-H “Content-Type: application/json”
-d ‘{
“value”: {
“image_resizing”: {
“resize_rules”: [
{“width”: 150, “quality”: 85, “fit”: “scale-down”},
{“width”: 250, “quality”: 85, “fit”: “scale-down”},
{“width”: 300, “quality”: 85, “fit”: “scale-down”},
{“width”: 545, “quality”: 85, “fit”: “scale-down”},
{“width”: 618, “quality”: 85, “fit”: “scale-down”},
{“width”: 949, “quality”: 85, “fit”: “scale-down”},
{“width”: 1023, “quality”: 85, “fit”: “scale-down”},
{“width”: 1024, “quality”: 85, “fit”: “scale-down”}
],
“default_format”: “auto”
}
}
}’

Can you give it a try again? I took some steps to fix that 10000 error but not sure if they will be effective.

If you keep getting the error, can you create an Account ticket and share your ticket number here? You can open an Account ticket here, https://dash.cloudflare.com/?to=/:account/support

Ticket ID: [3330349]

any news on a fix? its still not authenticating properly. Trying to do a delete on an image gives a similar error and I’ve even tried with the global API. Is there something wrong with the image section?

This topic was automatically closed after 15 days. New replies are no longer allowed.