Cannot add AAAA record for IPV6

I noticed that IPV6 was turned off and it will not allow me to enable it. Upon further reading, I need to add an AAAA record for my IP. It’s not clear if I retain the A record already pointing to my IP address or delete them to add the AAAA record - so, I tried both ways but neither work.

When I attempt to add the AAAA record with or without the A record active, the IP address block lights red as if that’s where the issue is.

I know Siteground has supported IPV6 since at least 2012 so I’m not really certain as to the issue. Any suggestions would be helpful.

IPv6 is usually turned ON, and won’t turn OFF. Can you post a screenshot of yours?

Can you also show a screenshot of that Red warning on your IPv6 address? It’s ok if you black out the last half of your IPv6 address.

I use only IPv6 for several of my domains in the DNS records here without complaint.

Here you go:

  1. That’s like mine. It’s stuck in the IPv6 position, and that’s good.
  2. Your putting an IPv4 address in an IPv6 (AAAA) box. IPv6 looks like 2606:4700::6811:b055. A bunch of large values with : between them.

If it’s greyed out does that mean it’s on and cannot be turned off? If so, why doesn’t my DNS records reflect the AAAA record.

Fair enough but do I have to manually add the AAAA record and if so - where would I get it the IP from because it’s nowhere in my DNS

Correct. Here’s what your DNS looks like, and it includes IPv6:

There’s really nothing more you need to do. But if SiteGround can provide IPv6 addresses for your website, you can certainly add them to your DNS here.

Okay. Their response has been spotty lately and they don’t want any questions other than if your site is down. Even then, they’ll tell you it’s not LOL. I’ll try.

I just want to see it in the DNS records because I noticed it was never in my DNS records with them either. I’m supposed to accept this on blind faith. Since Cloudfare is handling my records - I want to visually see it in place. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.