Cannot access my own website after enabled Cloudflare

Sorry that I am new to Cloudflare. Please kindly advise.
I cannot access my website (Error = Too many redirects) when enable Cloudflare,
Please help.

Set your SSL/TLS setting to “Full (strict)” here…

Otherwise, what is the domain?

Hi Sjr,

Thank you for responding to my problem.
I’ve try set SSL/TLS to Full (stick), however, it takes very long time until the website is starts loading and some time it cannot be accessed again.
Domain =

Your DNS records are not proxied, so requests are going direct to your server/host and not through Cloudflare…

Did you turn off the proxy? If it was always like this then redirects and any loading issues are down to your server/host.

Hi Sjr

Under DNS , Settings
I just turned on DNSSEC, Multi-signer DNSSEC, Multi-Provider DNS
Please correct me if I am wrong.

After I enable Cloudflare again, my website is accessible but really really slow…
It keeps rolling and rolling while CPU usage is very high as well.

Please kindly advice.

If I may,
Please kindly advise me on how to properly block traffic from some IP range.

Hey there,

I was able to load your website without issue after passing a managed challenge page and the loading time did not appear to be too long from my end.

To block traffic from certain IP addresses, we suggest you implement a WAF custom rule.