Can’t use idn domain on proxied

Answer these questions to help the Community help you with Security questions.

What is the domain name?

chigüibara.com

Have you searched for an answer?

Yes

Please share your search results url:

https://community.cloudflare.com/search?q=Proxy%20not%20working%20on%20idn%20domain

When you tested your domain, what were the results?
Didn’t work as expected.

Describe the issue you are having:

When I try to enable the proxied to make profit of the Cloudflare certs they don’t work at all.

What error message or number are you receiving?

SSL_ERROR_NO_CYPHER_OVERLAP


What steps have you taken to resolve the issue?

  1. Tried browsing the punny code instead
  2. Make sure with dig it was propagated
  3. Tried with curl and browser to see the difference
  4. Make sure server was not rejecting cloudflare testing same ip but with other non idn domains

Was the site working with SSL prior to adding it to Cloudflare?

Yeah, it was working, on plain http it works

What are the steps to reproduce the error:

  1. Enable proxied to root domain and www subdomain
  2. Wait the time it propagates
  3. Try to browse to page or try to curl it

Have you tried from another browser and/or incognito mode?

Yes, multiple of them

Attached you will find both screenshot of curl and Firefox

Is there an Active TLS/SSL certificate?

https://developers.cloudflare.com/ssl/edge-certificates/universal-ssl/enable-universal-ssl/#verify-your-certificate-is-active

Right now there is one, but I tried with both, having a certificate and not having nothing.

Are you still having issues with this?

We can see your domain is resolving over proxied records now.

Was there any changes made on your end?

Certainly there wasn’t any change from my side. The only thing I did, that I know was enabling full encryption once TLS was enabled on the node.

Maybe it was matter of waiting more than with non-idn domains?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.