Can’t reach my server (or nginx properly)

This certificate looks good BUT it is not my origin’s certificate. Could it be this mismatch that is cause me trouble? Why isn’t it showing that certificate?

I just want to reach my server and services safely, securely, and quickly. Thanks for your help.

Your Origin has a self-signed certificate, but you have set the SSL Mode to Full (Strict).

% echo | openssl s_client -connect 188.x.y.z:443 -servername brownfamily.se -tls1_2 2> /dev/null | sed -n '/Certificate chain/,/---/p'
Certificate chain
 0 s:/O=Nginx Proxy Manager/OU=Dummy Certificate/CN=localhost
   i:/O=Nginx Proxy Manager/OU=Dummy Certificate/CN=localhost
---

You have two options.

  1. Replace the certificate on your origin with a trusted certificate from a CA like Let’s Encrypt. This is the preferred option.
  2. Set your SSL Mode to Full
1 Like

Will delet and replace the cert and let u know. Thanks

Result INTERNAL ERROR AT NGINX - internal error - are you sure u used cloudflare’ s api token or pasted the complete token.

I used the cloudflare global api, should I generate a token instead? I created one. Not sure of all the options, but new error - can’t confirm zone-I’d for brownfamily.se. Is it associated with this cloudflare account?

Which of course it is.

UPDATE - stated from scratch. Delete and re installed the certificates , double checked ports, etc. and now seems to be working. Still need to add Wordpress or something as a front end to test that though. Thanks

I’m sorry to hear about this, what’s the error code? For 4xx client side errors (errors 400-499) visit 4xx Client Error – Cloudflare Help Center For 5xx server errors (errors 500- 530) visit Troubleshooting Cloudflare 5XX errors – Cloudflare Help Center And for 1xxx errors (errors 1000-1200) visit Troubleshooting Cloudflare 1XXX errors – Cloudflare Help Center

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.