Can’t get DoH to work

I enabled DoH on my Firewalla Gold router, with Cloudfare selected, and keep testing at on various iOS browsers, but no go. Here’s the connection information. Firewalla support wasn’t very helpful.

Have you been able to set your device(s) to without DoH and gotten success at

Hi sdayman,

Appreciate the quick response. I have DoH turned off and it still does not connect.

I don’t know why it says Amazon network, it it sure seems like you can’t reach the servers.