Can`t change alt-svc Header in Transform Rules

I want to use alt-svc HTTP header to guide Chinese visitors to the acceleration node 。
just like it

(ip.geoip.country eq "CN")

then
Set static
alt-svc = quic="cn.loli.pet:788", h2="cn.loli.pet:788"; ma=86400

But Modification does not take effect

I am afraid these are sent from Cloudflare and overwrtitten by HTTP/2 and/or HTTP/3 option from Network tab at Cloudflare dashboard.

And, even if you try to turn off HTTP/2 & HTTP/3 it might do the trick, but I am afraid that’s currently not possible anymore. At least disabling HTTP/2 not possible, except if you are not using an Enterprise plan, while for HTTP/3 I believe you can disable it.

Maybe something with Cloudflare Workers, but I haven’t tried neither tested. Could be I am wrong.

how fix it