Can not disable email-decode script

Hello!

I’m running a website + shop on Wordpress - theme Divi - and Cloudflare. When i’m performing a GT-metric test, a strange JS script is popping up.

https://meetsomnox.com/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js
(Same goes for my shop domain: shop.meetsomnox)

I first looked in the community and found the exact problem in this topic:

The problem is, I followed the advice in this thread, but the problem still occurs. I deactivated email obfuscation and purged all cache (yesterday). Unfortunately, the script is still showing up in the performance test.

Anyone got any tips? :slight_smile:

1 Like

If you have disabled the feature and you’re still seeing this, it may well be you have it cached somewhere at your origin.

Try this:

curl https://meetsomnox.com -sv /dev/null --connect-to ::1.2.3.4 | grep "email-decode"

Replace 1.2.3.4 with your origin server IP - this will send the request straight to your origin without Cloudflare and search your HTML to see if you have the JS embedded in there.

If it appears in there, your origin has cached or scraped & saved the HTML from Cloudflare - you would need to remove that manually.

This topic was automatically closed after 30 days. New replies are no longer allowed.