Can not change Wordpress Address or site address in dashboard


#1

Hi,

I can’t change either one of these in my Wordpress dashboard. Cloudflare SSL is working for all the pages on my site, but…there is a plugin that I am using to create a recipe, and their images are pointing to the http version and not the https version, making some of my site insecure.

I am using GoDaddy Wordpress Managed hosting, and I can’t change the Wordpress url to https.
I have tried to force SSL in configure.php, I have tried using the Insecure Content Fixer. It just will not change my Wordpress url to https. I also changed the path in PHP admin, did not make any difference.

Is this something I can do, or could it be a GoDaddy issue? Yes, i called them and they said it couldn’t be changed, but, I believe it can.

Would really appreciate some input, I have been working on this for over a week.

Thank you
Peggy


#2

Try page rules. Login to your CF account
And go to Page Rules. This could help.

Other things:

where did you change the site URL in PHPMyAdmin?
I don’t know the exact table (wp_config or wp_admin or…). but there are 2 rows were the site address can be changed. Long time ago since I had to do some changes there :joy:

You should also force the webserver to serve all traffic via HTTPS instead of WordPress only.

If everything fails, take the crowbar and add an…
.htaccess which redirects to https.
That are the things I for myself would try. But I stopped using WordPress a long time ago.

Oh, and I remember that I had a VPS where the http and https folders were different. Though I don’t believe that this is the case here.


#3

Hi Mark,

Thanks for the reply!

I already have page rules in effect.

I changed the site url in PHPMyAdmin, in the configure file…
I also tried inserting force https in the configure.php file

I have tried several plugins to resolve the issue, but none worked. I think GoDaddy is just blocking it somehow. But, I can’t believe I am the only one that is using a free SSL with Cloudflare with GoDaddy.

I have to get the Wordpress url changed to https, and I can’t seem to do it no matter what I try.

LOL, oh yeah, I have the crowbar primed and ready to go!

Thanks again,
Peggy


#4

Forgot to mention, all my site is showing SSL except for a plugin that is using http in their image files.


#5

You can manually change the Wordpress Address in wp-config.php (or is this what you mean by “force https in the configure.php file”?
https://codex.wordpress.org/Changing%20The%20Site%20URL

Do you also have Cloudflare’s Crypto Page set to “Always Use HTTPS” and “Automatic HTTPS Rewrites”?

If all that isn’t helping, some plugins can be stubborn. Which plugin is it?


#6

HI Sadyman,

Thanks for the reply!

Yes, I have tried to force https in the configure file.

Yes, I have Crypto set to always use https rewrites

The plugin is Easy Recipes, the free version.

But they are showing just http for all THEIR images.
I have tried to change everything…somehow GoDaddy is blocking letting me use https in the dashboard.
I think it has to be a GoDaddy problem with using free certificates

when I try and change the Wp address and the site address in Wordpress admin, it is greyed out and I can’t.

As long as I post anything that does not have that plugin, every thing is secure, but the links they are using in the program.

Very hard to explain/


#7

The greyed out URLs in your Settings page should match what you have in wp-config.php. It doesn’t?

A while back, you said you were using Flexible SSL. Is this still the case?

Can you give me a link to the Easy Recipes plugin? Is it this one?

If you are still using Flexible SSL, have you tried the Flexible SSL plugin?


#8

I actually had changed the address in the “wp_options” table, and I had tried to force it to use SSL in the wp_configure.php, by using
define (‘FORCE_SSL_LOGIN’, true); and define(‘FORCE_SSL’, true);
Those didn’t work for the links in the Easy Recipe plugin either, yes, that is the correct plugin you that you showed.
I put everything back the way it was before I started last night before I went to bed.
This morning, it is all showing secure,even the links in the Easy Recipe plugin.
The urls are still greyed out and show http. but, everything seems to be secure anyway!
Yes, I am still using the flexible plan with Cloudflare. This all started when I changed from a regular website with WP installed and migrated to a Managed Wordpress. I didn’t have this problem when it was just a regular website.
For some strange reason it’s showing secure now, even though I put everything back to the way it was in the beginning!
Thanks so much for you help, I really appreciate it.


#9

Thats odd. Next time you could force your webserver to redirect. Just edit your Apache config (backup first!)

EDIT 3:
can we have a code feature please :joy:

https://wiki.apache.org/httpd/RedirectSSL


#10

I guess the good news is you have a consistent setup where WordPress is all in HTTP so Flexible will work.

I’m curious, though. Your Managed Wordpress doesn’t offer SSL? They usually do.


#11

Acutally, i have https now. I’m sorry if I confused you!

Yes, they offer the SSL, but it’s way to expensive!

I tried the other settings other than the Flexible, and the site wouldn’t open.

It only seems to work on Flexible.

Thanks!


#12

Thanks!

it’s all strange, since I changed from a regular website with WP installed, and migrated to a managed WP.

I had no problems with SSL and Cloudflare with just the regular website.

For some reason, it’s all secure now, have no idea why!

Thanks again and thanks for the code link!

Peggy


#13

Cosmic radiation :wink:


#14

This topic was automatically closed after 14 days. New replies are no longer allowed.