Can not add or edit payment method

We are having a problem updating our payment method on our account. Tried both updating the old card and adding a backup, got the same error:

Refer to dash.cloudflare.com/?account=support for assistance. For security reasons, there is a problem with your billing profile. (Code: 1292)

Certainly opened a ticket (#2632067), in which we were told to wait for security teams’ response to the matter. However, we were yet to hear any response after 10 days.

Our main concern is we have an important domain name with upcoming renewal on the 25th of December, and are really worried that we will hit the festive season before the issue resolved. In order to avoid any disruption, we tried moving domain to another registrar, but Cloudflare does not allow that either. We see a blank page when we try to access domain’s settings and we see this response message on the console:

{ code: 10000, message: "Registration access forbidden: account blocked" }

I see other posts with the same issue marked resolved in this forum, so trying our chance here. Would appreciate any suggestions.

Sorry for the issue you’re facing, but only the team mentioned and I see Support has escalated your ticket to that team.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.