Can not add .cl domains

Hi, you bought a domain a few days ago and Cloudflare doesn’t add it because it says the domain doesn’t exist. What’s going on? The domain is . The domain provider asked me for a server on a mandatory basis so I put the cloudflare ones, the provider does not have its own dns services so I cannot assign another.

$ whois
%% This is the NIC Chile Whois server (
Domain name:
Registrant organisation: 
Registrar name: NIC Chile
Registrar URL:
Creation date: 2020-02-27 02:32:36 CLST
Expiration date: 2021-02-27 02:32:36 CLST
Name server:
Name server:

But cloudflare says: is not a registered domain

1 Like
1 Like

means the domain isn’t registered, the domain has no name servers, the domain name servers can’t be resolved, or the domain name servers don’t contain any DNS records and as a result the domain can…

But not having a valid DNS server assigned does not mean that the domain does not exist, if I do not have a domain server, how can I create the registration in cloudflare if it is the only domain name service I use? Do I have to have my own DNS service or have another service contracted to use cloudflare?

Perform the validation of the domain names to know if a domain exists or is not an erroneous practice that causes false positives, a domain can exist without it having a dns name assigned as it is the case of the newly acquired .cl domains. They should make a whois query to know if the domain exists or not.

Now, how do I get cloudflare to add my newly purchased domain if I don’t have another dns service besides cloudflare?

You can’t register domains with Cloudflare. If you want to use Cloudflare as registrar you need to buy your domain elswehre First and transfer it afterwards.

If you want to add your domain to Cloudflare and use their services, there must be valid nameservers set (registries don’t even allow to buy a domain without nameservers assigned, that’s the registrar’s job). Just set a DNS record via your registrar’s control panel. And may it just be one A record to

1 Like

I don’t want to buy a domain with cloudflare, I want to register a domain in the Cloudflare DNS service.

The domain provider does not provide me with a DNS control panel, it only requires me a domain name server. Personally I do not have a DNS service other than cloudflare.

I think the problem is not which DNS service you use before creating the enrollment in Cloudflare or bureaucratizing this Cloudflare problem, in my opinion the problem is that Cloudflare performs an incorrect “domain existence” validation.

If my domain provider does not provide me with a DNS service, how can I register the domain name that I purchased several days ago in the Cloudflare DNS service?

Hi @yhojann.aguilera,

I won’t argue about whether Cloudflare’s chosen validation method is the most appropriate or not, the point is that - for some or several reasons - the company has chosen to validate domains in that way and it is well documented on this support page (referenced from the link that @sdayman had already shared):

Before a domain can be added to Cloudflare, the domain must return NS records for valid, working nameservers. NS records can be checked via third-party online tools such as or via a command-line terminal using a dig command:

dig +short ns

Additionally, the domain must return a valid SOA record when queried. SOA records can be checked via third-party online tools such as or via a command-line terminal:

dig +short soa 2029202248 10000 2400 604800 300

Note that both queries dig +short ns and dig +short soa do not return any value - and that’s why the domain cannot be validated.

As @MarkMeyer said, providing nameservers to newly registered domains is the job of the registrars - and it’s really unusual to find cases where this doesn’t happen.

I suggest that you first contact your registrar to clarify if they could provide you with temporary name servers just in order to validate the domain and then change them to those provided by Cloudflare.

If they can’t help, please contact Cloudflare support and ask if there is an alternative to the current method.

I hope this issue will be solved soon and that it won’t take long for you to make use of Cloudflare’s amazing features!

I understand then that in order to enroll a domain in cloudflare I must have a temporary domain name server, this is quite strange.

If I had to check if a domain is functional, I would use dig or any DNS query to see if the domain name has an assigned IP address, but a domain name service cannot validate a domain before being enrolled by checking if it already has Another domain name or not. It’s like saying, ok, your website needs a hosting, but you must first upload it to another temporary hosting to transfer the files.

Unfortunately, does not have its own primary DNS service, generally in Chile things are done halfway and is no exception, it is like selling shoes without laces, so my only alternative is to contact cloudflare .

I have noticed that the only communication channel as a support for Cloudflare is the community, besides this by clicking on the link that says “technical support” it sends me to a page with questions and answers, but I can’t find Some means of contact that can help me with this problem.

In the URL requires me to select a domain, that means that I cannot make question tickets about an unregistered domain. Once you add a domain to cloudflare everything is fine, but if you have problems adding a domain you are practically alone because there is no official support flow for this.

Try (they offer free DNS)

If there are other domains in the account to which you want to add this one, you can create a ticket by selecting some other domain and then clarify the situation. Another option is to contact support via email (support AT cloudflare DOT com) - in this case, take care to send the message from the email associated with the account for which you want support.

Have you tried the Hurricane Electric DNS as a workaround?

This topic was automatically closed after 31 days. New replies are no longer allowed.