Can no longer use my facebook login

Hello,

Since Cloudflare changed its settings on the server I can no longer use my social plugin that give my users the ability to logon to my website using their Facebook account, nothing has changed with my plugin settings and nothing has changed with my hosting service (SiteGround).

I even went into the Cloudflare Firewall settings and added in the tools section Facebook ASN’S numbers Whitelist, and added the IP address in Facebook settings and I still get the error below:

It throws the following error :

URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs.

This is the Debug info from my plugin:

Debug: Facebook
Network connection successful: https://graph.facebook.com/v3.2/oauth/access_token

  • Trying 157.240.18.15…
  • TCP_NODELAY set
  • Connected to graph.facebook.com (157.240.18.15) port 443 (#0)
  • ALPN, offering http/1.1
  • Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
  • successfully set certificate verify locations:
    CAfile: /home/thetalkb/public_html/wp-includes/certificates/ca-bundle.crt
    CApath: none
  • SSL connection using TLSv1.2 / ECDHE-ECDSA-AES128-GCM-SHA256
  • ALPN, server accepted to use http/1.1
  • Server certificate:
  • subject: C=US; ST=CA; L=Menlo Park; O=Facebook, Inc.; CN=*.facebook.com
  • start date: Jun 6 00:00:00 2019 GMT
  • expire date: Sep 4 12:00:00 2019 GMT
  • subjectAltName: host “graph.facebook.com” matched cert’s “*.facebook.com”
  • issuer: C=US; O=DigiCert Inc; OU=www.digicert.com; CN=DigiCert SHA2 High Assurance Server CA
  • SSL certificate verify ok.

POST /v3.2/oauth/access_token HTTP/1.1
Host: graph.facebook.com
Accept: /
Content-Length: 0
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 400 Bad Request
< WWW-Authenticate: OAuth “Facebook Platform” “invalid_request” “Missing redirect_uri parameter.”
< Content-Type: application/json; charset=UTF-8
< facebook-api-version: v3.2
< Strict-Transport-Security: max-age=15552000; preload
< Pragma: no-cache
< x-fb-rev: 1001045106
< Access-Control-Allow-Origin: *
< Cache-Control: no-store
< x-fb-trace-id: F855J+iOnm9
< x-fb-request-id: Avnz94UbuYWP4_8zjiUVGej
< Expires: Sat, 01 Jan 2000 00:00:00 GMT
< X-FB-Debug: 2cpbECyfBMjooLUxKFMbkji+T0s1NHjSn4R2IgOpIYrchfWqA3RTpr8fzST1fZvHEOhIrMd/5Uksf7T+dXGxNQ==
< Date: Mon, 12 Aug 2019 12:49:59 GMT
< Connection: keep-alive
< Content-Length: 129

  • HTTP error before end of send, stop sending
    <
  • Closing connection 0
    {“error”:{“message”:“Missing redirect_uri parameter.”,“type”:“OAuthException”,“code”:191,“fbtrace_id”:“Avnz94UbuYWP4_8zjiUVGej”}}

Can you pause Cloudflare and check if you are still seeing the issue? How do I temporarily deactivate Cloudflare?

If the issue persist after Cloudflare has been paused, it means that there is an issue with your origin, Cloudflare is only operating as your DNS provider while it is paused.