Can connect to guacamole trough quick tunnel, but tunnel created from windows CLI is not working

Hello Community / Support,

I’ve managed to get apache guacamole set up trough docker on my windows home system, configured with alternative RDP.

I can reach my localhost:8080 locally and use it normally, and I could even reach it from quick tunnel.
However, when I try to configure my own tunnel, I can’t get it to run.

Here I tried to configure my subdomain to point to it, also added NS-record from my domain-provider.

Tunnel points to my subdomain.

I did not set up any network,



Like this,

credentials-file: C:\Windows\System32\config\systemprofile.cloudflared-—tunnel.json

Uncomment the following two lines if you are using self-signed certificates in your origin server

noTLSVerify: true


  • hostname: mysubdomain.domain
    service: localhost:8080
  • service: http_status:404
    logfile: C:\Cloudflared\cloudflared.log

Tried unchecking those certs if there was any security issue. Do I need to port forward 80 & 443, on router, when setting up tunnel on machine instead of on docker?
Also tried moving credential file to my User/.Cloudflared/tunnelcredential.json (generated from CLI)

Read somewhere that with tunnel this is not necessary, but maybe it’s only for docker?

And then I start tunnel with, cloudflared tunnel run (reading error messages on github, someone mentioned some edge error)

2023-07-03T10:51:33Z ERR Failed to serve quic connection error="Unauthorized: Invalid tunnel

Before that I had,
2023-07-03T09:57:45Z INF Registered tunnel connection connIndex=1 connection=71eb9a67-869b-454b-a012-33ade080eae3 event=0 ip= location=AMS protocol=quic
2023-07-03T09:57:45Z INF Registered tunnel connection connIndex=2 connection=e9348c17-968d-4c0a-9879-f48b17663079 event=0 ip= location=MAD protocol=quic
2023-07-03T09:57:47Z INF Registered tunnel connection connIndex=3 connection=006c05d7-a76f-4e39-9e99-1c6a3648da94 event=0 ip= location=AMS protocol=q

Any clues?