Caching problem: Cloudways+Cloudflare Pro+WPSuperCache

Hi everybody,

I have a problem on my website When I publish a new post, it immediatly appears on ‘Desktop’ but is delayed by around 4 hours on ‘Mobile’.

I use Cloudways+Cloudflare Pro+WPSuperCache

When I purge Cache on Cloudways (Varnish) and Cloudflare (Purge Everything), then the posts reappear on ‘Mobile’ too…

Server-level cache @Cloudways: Varnish; Cache Lifetime: 4h (14400s); no other types of caching enabled (Redis or MamCached).

Cloudflare: TTL: 2min (120s)

WP Super Cache: Cache Time-Out: 60s; Timer: 90s.

I tried without WP Supercache and I had the same problem. So I think it is not related to that Wordpress Plugin.

It seems that the Varnish Cache Lifetime of 4 hours isn’t ‘overwritten’ on ‘Mobile’ and if I don’t clear the Varnish Cache, the posts will only appear 4 hours later.

Is that possible?

Is there a way to solve this issue?

Thank you,



It seems that Varnish may be the culprit here.

Are you using a plugin to purge pages from Varnish cache when there’s an update? If not, you could try installing one (there are several in the WordPress repository, but one that gets lots of attention is Proxy Cache Purge – WordPress plugin | Then see if that solves the problem.

If it does, you’d have the option of 1) disabling Varnish and keeping only WP Super Cache for origin caching; or 2) keeping Varnish with the plugin that purges pages when something changes.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.