Caching of requests has decreased without any changes to cloudflare settings

For the last 15 days there has been a sudden drop in the number of requests served by cloudflare. There has been no change in any cache rules. I have gone over the logs. Only thing that has happened is a cache purge. But we do this once every 2-3 weeks, so don’t know what is causing this.

Possibly any change on your server which changed the caching headers and now prevents Cloudflare from caching?

Whats the URL? Are your visitors from a very diverse set of locations or rather from the same area (regarding the cache purge and the likelihood of the datacentres simply needing the recreate the cache globally)?

1 Like

See my headers below:

Your origin returns the following headers:
< Cache-Control: max-age=31536000, public

$ curl -svo /dev/null -k https://www.metro-online.pk/images/appicon.png --resolve www.metro-online.pk:443:158.106.130.202 2>&1 | grep '< '
< HTTP/1.1 200 OK
< Date: Sat, 30 Nov 2019 13:18:01 GMT
< Server: Apache
< x-frame-options: DENY
< X-XSS-Protection: 1;mode=block
< X-Content-Type-Options: nosniff
< X-Permitted-Cross-Domain-Policies: none
< Last-Modified: Thu, 22 Nov 2018 10:49:18 GMT
< Accept-Ranges: bytes
< Content-Length: 7576
< Cache-Control: max-age=31536000, public
< Expires: Sun, 29 Nov 2020 13:18:01 GMT
< Strict-Transport-Security: max-age=31536000
< Set-Cookie: HttpOnly;Secure
< Content-Security-Policy: frame-src https://secure.livechatinc.com/ https://metroonlinepk.firebaseapp.com/ https://metro-online-web.firebaseapp.com/ https://app.adfilius.com
< Access-Control-Allow-Origin: *
< Connection: close
< Content-Type: image/png

Cache is bieng BYPASSED at the moment.
Any help would be great.

Try removing that “Set-Cookie” header. It is not valid anyhow and cookies can prevent Cloudflare from caching.

1 Like