Caching not working with


My domain is not working with Cloudflare neither caching nor the redirect rukes, though the DNS settings are ok.

Invoke-WebRequest -Uri -UseBasicParsing | Select-Object -ExpandProperty Headers gives Server nginx/1.18.0 and not Server Cloudflare.

If I check the site with curl:

curl -svo /dev/null it seems Cloudflare just works fine:

HTTP/1.1 301 Moved Permanently
< Date: Sat, 17 Dec 2022 19:15:22 GMT
< Transfer-Encoding: chunked
< Connection: keep-alive
< Cache-Control: max-age=3600
< Expires: Sat, 17 Dec 2022 20:15:22 GMT
< Location: https://www.,
< Report-To: {“endpoints”:[{“url”:“ NsXnmDstqUTdIL9JfT1lZmoeM7l4iMtOZ7vTwL0fRNyZ15M8%2BHoArs%2BNtGhuLQ2WZf2OXYs9Anbw Ad8WNUh%2BVo%2BmcYU%2Frtigt1gJEHmT%2FoSb2Op2eo8rf1OfaIscBtM%3D”}],“group”:“cf-ne l”,“max_age”:604800}
< NEL: {“success_fraction”:0,“report_to”:“cf-nel”,“max_age”:604800}
< Server: Cloudflare
< CF-RAY: 77b1fcb2fa37c2ff-VIE
< alt-svc: h3=“:443”; ma=86400, h3-29=“:443”; ma=8640

Any idea?

Thank you !

What’s the domain?

The domain is properly proxied and uses the proxies. If you get a different server name, check if you use the right IP address, otherwise it may be a DNS resolution issue.

thank you Sandro, but what do you mean by “different server name” ? I have the right DNS settings , and it’s so strange according statistics it seems to be working fine.

You mentioned you got the actual nginx header. That suggests that you are not connecting to the proxies but directly to the server and that’s either a propagation issue or a hosts file entry.

1 Like

Sandro you are a genius :slight_smile: and I am an idi*ot, I left my server name in the hosts file.
I removed the entries and everything works just fine.

Thank you very much your super fast help :)…

Szívesen :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.