Caching Nightmare 😔

Hi, I recently setup my domain with Cloudflare and everything seems to be working good so far, absolutely love it!

I have a Heroku server which my developer does the new deployments, we had a bug and made changes and viewed the direct Heroku build link and it works good. For some reason Cloudflare is caching the old which has the errors.

I’ve set Developer mode on and then it shows my latest changes with my working site, when I take off Developer mode and purge cache whether it’s “Purge Everything” or “Custom Purge”, it’s goes back to showing the old cache. I’ve even cleared my browser caches and still not showing the new changes from my Heroku build.

Is there a way to completely reset the cache in the Cloudflare system?

Any help is greatly appreciated!
Thank you.

That would be Purge Everything.

What’s the URL that’s showing old content?

1 Like

Hi sdayman!

Thanks for your reply, the URL of the site is: - This main domain link is the one having the cache issue with an error. If you open developer tools and view console window - We had an issue with JS imports

And the direct Heroku Build Link which is working is: - On this link, the JS imports error is fixed and working properly.

So If I turn on Developer mode the main domain works fine, and if I turn it off & purge everything, still shows the old cached page error.

Your help is much appreciated!

If it JS, the first thing I recommend is to disable Rocket Loader in Speed -> Optimizations.

1 Like

Thanks for that suggestion sdayman!
I’ve disabled Rocket Loader, purged cache and still the error continues to persist.
When I purge cache, it works for 1 refresh and then when I refresh again, back to old cache. :thinking:

Very weird.

It appears you have a Page Rule for Cache Everything. Have you tried disabling that Page Rule? A picture of your page rules would also help in debugging this.

1 Like

I just recently added this to see if it made some difference, but I think it made it worse.
I disabled “cache everything” and purged cache for that specific URL. Attached is a screenshot of my page rules which I only have a redirect enabled.

I’m just not sure what else to do :frowning:

Thanks for your help man

I don’t see any errors from my side.

1 Like

Hey sdayman & erictung

Thanks for your replies, I think I may have found the culprit, it may have been due to the:
Speed => Optimization => Auto Minify

When I unchecked the “JavaScript” option, purged cache. It seems to be loading correctly from my Heroku site. Not sure why the Minify JavaScript option would result in loading the old cache which had the JavaScript import errors? Kind of baffled there :thinking:

I thank you both :pray:

Have a good day and weekend ahead, I have to start learning what I can do with this worker I setup :slight_smile:


That’s a good question. It’s not supposed to minify inline JS, such as would have been in your cached HTML. However…a Javascript file doesn’t get minified until it’s a HIT, so that would explain quite a bit. I don’t think it had to do with the Cache Everything rule, as it turns out.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.