Caching "immutable" content

#1

After adding “immutable” to the Cache-Control header, CloudFlare no longer appears to cache responses.

Could anyone confirm this is a bug and when it is likely to be fixed?

Example request header:
Cache-Control: public, max-age=31536000,no-transform,immutable

Response headers never contains after subsequent requests:
CF-Cache-Status: HIT

Expect response to be more likely to be cached.

#2

For that header to work you’d need to add a page rule with the setting “Origin Cache Control” set to ON.

For details:

2 Likes
#3

Thank you for your fast response. Caching is now fixed.

2 Likes
closed #4

This topic was automatically closed after 14 days. New replies are no longer allowed.