Cached files


#1

HI, lately i am having a booger of a time getting my file changes to get into cache and on the page. Some times its like 20-30 min regardless of what i do to prevent or refresh it. Maybe i dont understand the process or maybe i am missing or expecting something that does not happen. The changes really take a long time if its a css file or a image file change.

Here is my process:

I make a change to a css file.
Then i pull up the css file in the browser to see if the change is there
If not there then i clear that files cache or clear everything in the CF cache section.
Then i usually run ccleaner but will bypass the browsers
Then i will clear my local dns cache via the windows command console
Then i will press control f5 to get the new page - and its still the same
Then i clear the browser history, still the same.
So then i turn on CF dev mode under the cache tab and check the browser again
Still the same.
Then i go through the process all over again…
And in about 20 min or so my change appears.

This slows down my developement to a snail crawl, costing me hours of time to do a few changes.

What am i not understanding about the process?
Where is the cached file hiding?
How do replace what CF has quickly and see my changes faster?

Thanks so much :slight_smile:


#2

That is exactly what development mode is for. If it is still cached, it is either a local issue or you have some other proxy inbetween (ISP, network, and alike).


#3

I thought so but it was not working so i wanted to ask.

So you are saying that as soon as i turn that dev mode switch on, i should be able to see the new changes in the browser(barring any issues with the browser)?

If yes then as you say the problem is somewhere down the line.

A few times i thought it looked like i had to leave the cache page and go back into it and then hit dev mod to get the change. But that could have just been a coincedence.


#4

The moment you turn development mode on, I’d expect the caching to seize. Maybe you could aditionally purge the cache, but - unless there is a bug in Cloudflare’s code - anything caching related should not be on Cloudflare’s side anymore.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.