Cache status is always BYPASS when HTTP Request Header Modification is enabled

Does enabling HTTP Request Header Modification make the cache status always BYPASS?

I suppose it depends on the header. I’ve added a header and I still get a HIT on all my resources.

Yes I think that is a possibility. But I checked the header of the response from server which did not have anything related to cache.

What’s a URL that’s showing BYPASS?

I am actually using the transform rules for BackBlaze B2. You can try https://b2.halu.lu/Snipaste_2021-11-08_16-50-51.png

It is now public bucket, but I still enable the Request Header Mod rule, so it’s BYPASS now.

The origin is https://f002.backblazeb2.com/file/halulu/Snipaste_2021-11-08_16-50-51.png
I also enable a URL Rewrite rule but that does not affect cache status.

I do see the BYPASS, and I don’t see a cache-control header.

My suspicion is because it’s a Private bucket. I don’t think adding the “Authorization” header is the reason the response isn’t cached.

No, this is a public bucket now, and it’s HIT/MISS when I disable the header.

Sorry, I missed that bit about the public bucket.

My backup theory is that with an Authorization header, Cloudflare takes that as a signal that it’s a private connection and to not cache it for fear of someone else coming along without the Auth header and seeing the Cached response.

So can I force Cloudflare to cache? I tried Page Rule but did not work.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.