Cache settings

cache

#1

Hi @ Cloudflare Community,

I’m a Cloudflare newby, running a hobby-website https://oentsjerk.eu, about the local weather and using the free plan.

In the ‘Grafieken’ menu, I’m presenting near real-time graphics (#.gif). I have set Caching to ‘Ignore query string’, the Browser Cache Expiration to ‘Respect existing headers’ and made a page rule with parameters xxx/b/* and the setting Cache level = Bypass. But still I’m not able to refresh the needed graphics, running behind now for ~2hrs :frowning_face:. Any ideas or tips to solve this?

Regards, Keimpe.


#2

Can you provide a specific URL of an image with this problem? I went to the Grafieken menu and chose the 6h graph and see that the image is cached (cf-cache-status: HIT), but it’s not in a /b/ path:

https://oentsjerk.eu/wp-content/uploads/WD/curr6hourgraph.gif

The Page Rule should override whatever the general Caching settings are. Can you post a screenshot of that Page Rule?


#3

Thanks @sdayman, in this link http://urqr.nl/CF/Cloudflare_19012019.jpg you will find the combined screenshots of the cache-settings, as well as the page rule.

Regards, Keimpe


#4

It looks like you want to bypass cache for anything with a “b” in the path. The .gif image I posted above does not have a “b” anywhere in the path.

What is the URL of something that you want to bypass?


#5

This one: https://oentsjerk.eu/6h-voortschrijdend/


#6

That’s the one I posted. The .gif URL doesn’t have a “b” in the path.


#7

So I have to change to https://oentsjerk.eu/ / to bypass everything?


#8

Hmmm, I tried to type https:// oentsjerk.eu-slash-star-slasch-star


#9

Change that Page Rule to match oentsjerk.eu/*.gif

Since you probably only use GIF files for realtime updates, that would be a safe Page Rule.


#10

OK, thanks, I’ll give it a try :slight_smile:


#11

YES!! it’s working, thank you so much for learn me!


closed #12

This topic was automatically closed after 31 days. New replies are no longer allowed.