Cache Rules ignored by APO?

We use APO on our website here and, for the most part, it works great. There is one URL that I need to never be cached, however, and I realized today that this is not functioning properly.

I have tried both a Cache Rule and a Page Rule, neither of which successfully causes the cache to be bypassed.

Cache Rule:

Page Rule:

With either (or both!) of those in place, and then purging the cache and waiting a minute, I still get this from CURL:

dave@miniOffice ~> curl -I https://www.macgeekgab.com/rss/mgg_mailchimp_video.xml
HTTP/2 200
date: Wed, 17 Apr 2024 17:22:00 GMT
content-type: text/html; charset=UTF-8
cf-ray: 875e184239171107-ORD
cf-cache-status: HIT
cache-control: no-store
last-modified: Wed, 17 Apr 2024 17:16:22 GMT
vary: Accept-Encoding
cf-apo-via: tcache
cf-edge-cache: cache,platform=wordpress
x-powered-by: PHP/8.1.11
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v4?s=vQVKRD89OInK7L%2B7ozXw546FX8yHmY23XFneZ15ahqTrR1Wdn1ZQ%2ByZvXxj96rYQFlRA7LT5PwAky1D7ccxXuYX3V2xtKQRbFoyD1kPA23BknTfV8r29D3RefiJo4p5XWou479I%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
alt-svc: h3=":443"; ma=86400

Is there any way to “teach” Cloudflare to bypass the cache for a single page while APO is still active on the rest of the site? I see from the docs that:

But clearly this doesn’t seem to be behaving in that way.

Am I doing something wrong? Or am I perhaps misunderstanding APO? Or is it just that APO is not flexible in this way at all?

Thanks!

Hi @dave15

Could you please try and disable Cache By Device Type in your Cloudflare dashboard, and see if this solves your issue?