Cache performance so bad, we're having to enable development mode

Our end users called in, saying the web app performance is so bad, it’s unusable. Surely enough it is. It turns out, CF cache is taking a long time (10.00 sec plus) to return a file. We are having to turn on “Development Mode” - where all requests from outside hits the origin servers directly - and problems are solved. It’s a relatively new issue, starting around 12/18/2021. Has there been any new releases or changes?

I’ve been having a similar issue started around the 17th, nothing in the error logs on apache but end users complaining it’s not running correctly seems like a similar issue to yours

1 Like

Does entering “Development Mode” help in your case?

May I ask what cache options have you got selected and using at Cloudflare dashboard?

  • Browser Cache, Edge Cache, Cache Level Standard/Everything, Origin Cache Control …

Using a Free or a paid Cloudflare plan?

Maybe using APO for WordPress or?

Any cache at the origin host/server like x-cache, Litepseed, Nginx, or a plugin for WordPress like WP-Rocket, etc.?

Is there some firewall at the origin host/server limiting or throttling the connections from Cloudflare network?

May I ask like CSS, JS, image? Or rather cached HTML webpage?
What do the cf-cache-status HTTP headers saying? HIT or?

Maybe something from:

Let me see if I can answer them in order:

Using a Free or a paid Cloudflare plan?
We are on the professional plan.

May I ask what cache options have you got selected and using at Cloudflare dashboard?
.
i think it falls under “Origin cache” category…

Maybe using APO for WordPress or?
We are using our own asp.net app on IIS.

Though, I don’t think that’s relevant because only the environment we serve through CF experience this slowness. And, to add, enabling “Development Mode” to BYPASS the caching makes everything work snappy. Or, routing these VMs outside of CF will make them work snappy too, so I don’t think what our origin server is doing is the root cause.

to return a file

.js. .css, anything…we can see them on Chrome F12 debug. When routed through CloudFlare, whatever.js…whatever.cs…all takes like 14000 milliseconds, that’s over 10 secs. And to the end user, this makes the site looks like it’s broken. When I go to CloudFlare’s top page, enable “Development Mode”, then the CF origin cache will not kick in, all end user access will go direct to the origin server, and everything is snappy.

On the origin server (IIS), I don’t think we have anything unusual for caching. We certainly do not have any plug-in or third party for that. Plain jane IIS and out ASP.NET app, that’s it.

I hope this helps!

The problem started sometime between Dec.17 ~ Dec.18 and still persists. We did not change anything on our end. We were alerted to the site being down by customer calls, and sure enough, out site didn’t render - after troubleshooting, we found that disabling CloudFlare would make it go.

THEY FIXED IT!!!

Whatever it was, it was fixed on CloudFlare’s end.

As of Dec.21th, the cache serving performance is back to normal. We don’t have to take turns keep putting it in Development Mode every 3 hours anymore. Hooray!

2 Likes