Cache not updated in IE 11 and Safari

Hi all,

I have a wordpress site behind cloudflare pro and the homepage is not updated only in IE 11 and in Safari.

No cache plugin is installed in wordpress and in ALL other browsers it works fine.

Any ideas?


Not without knowing the homepage URL and images of what the updated homepage should look like.


The url is

What I see is

What I should see is

Thanks :slight_smile:

I can not replicate the problem you see.

The best way to fix this issue is, clear all caches on CloudFlare by going to

Caching tab >> configuration tab >> purge every thing

And then, do hard refresh all of your browsers.

I hope this will help.

Well the thing is that I’ve done this 4 times and yet it brings the new version BUT the visitors continue to see old news. It is as if cloudflare does not understand after it delivers the page to send to the client’s broswer headers to refresh their content.

You are actually seing the old version of the site :slight_smile:

My picture with the vaccine is the latest news.

If other people have cached your pages already then the best way to handle this is use queries with your files you think not being seen by others. Here is an example if you are using php…<?php echo date("h:i:s"); ?>

But, make sure your settings on CloudFlare have no cache for query strings.

Darn it.

Go figure. Now that I’m on my laptop, I can replicate the problem. Firefox shows the correct version, but Brave and Safari do not.

Ah…you’re using APO and it’s not updating the Cloudflare Cache. Try a Purge Everything.

What is APO ? :frowning:

In general I dont use any caching/optimization plugin in wordpress except the cloudflaire plugin

Automatic Platform Optimization (Just WordPress for now).

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.