Cache not clearing on Wordpress site

Every time I make changes to my site it takes several days or weeks to reflect the changes across the globe. Even when I purge the cache or turn Cloudflare caching off. I have a wordpress (no caching plugins) site hosted on a Vultr VPS with WHM/Cpanel installed. I have NGINX Caching which I cleared and I have tried restarting the hosting server and apache several times. Any ideas what’s going on?

I should also add I have many other Cpanel accounts on this server and many other wordpress sites on this server with some on Cloudflare and some do not, but none of them have this issue.

This site has around 20,000 visitors a month (according to Google Analytics) and 45k (according to Cloudflare) not sure which one is correct, but it’s many times more than anything else on the server so I don’t know if that makes a difference.

Also there is a node.js app embeded into this wordpress site via a custom plugin. Not sure if that makes a difference.

That’s strange :thinking:

May I ask if it is the Engintron maybe then? :thinking:
If yes, then contact your web hosting provider to flush & clear the origin host cache.
Use “Purge Everything” from the Cloudflare dashboard → Caching → Configuration.

If presists, kindly ask your web hosting provider to exclude your domain from engintron / Nginx cache on their cPanel / system.

Interesting :thinking:

May I ask you to post and share the URL example to the particular resource in a bracketed dot [.] notation with us so we could double-check, troubleshoot and provide some feedback information reagarding the HTTP cache headers? :thinking:

I wonder which HTTP cache headers are set for it.

May I ask if you’re using some custom-made Page Rules at Cloudflare?

Furthermore, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

You could also determine if this behaviour continues even by using a “Pause” option at Cloudfalre as follows:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect
  4. Make sure site is working as expected with HTTPS.
  5. Retry and make sure there are no unknown HTTP cache headers from the origin
  6. Upon success, un-pause

Other helpful articles:

Thanks for the detailed reply.

The domain name is squaremyimage[dot]com

I have tried turning off Cloudflare as suggested waited 5 mins and nothing changed. Also purged everything many times.

Restarting Apache on the server also didn’t do anything. There is not much I can ask the host to do I just rent the cloud hardware from vultr and mange the server myself with WHM I installed.

I’ve used several browsers in incognito (different devices) and have used a screenshot website to take screenshots from an api. I’m still seeing the old version.

No custom page rules, the site is only one page.

I just changed my Caching Configuration to Browser Cache TTL from 2mins.

Here is a loom video I made of the site. Hope it’s ok to share this:

[loom video id 25e198e6bd444715857fa3604c2bb563](