Cache not clear automatic

i had purchase Cloudflare APO Plan for my website , but i have a issue whenever I post a new article in any category , it will not updated realtime when we clear or stop Cloudflare then new artcile come please suggest us how can resolve this issue.

Is the homepage or any other configuration set to 4 hours or longer maybe? :thinking:

May I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

browse cache TTL -4 hours
more details check attachment.

When we close the APO, it gets fixed, when we enable the APO, then this issue is coming. We also use litespeedcache plugin. this is wordpress website

I suspect this might be related to the discussion here:

If you are using the cache by device type option and you are able to disable that for now then that is a workaround to try.

1 Like